[zorp] problem with apt-get update on debian sarge

Balazs Scheidler bazsi at balabit.hu
Fri Feb 22 12:49:48 CET 2008

On Fri, 2008-02-22 at 11:06 +0000, Tom Carbert-Allen wrote:
> Dear All
> I have just installed debian sarge minimal i386 and added the 3.1 apt sources from the www.balabit.com website but when i run
> apt-get update
> All i get is 404 errors
> The box has full network connectivity through a http proxy and can download packages from other souces. What have I done wrong?
> my /etc/sources.list
> # Zorp & ZMS (zorp-os based)
> deb https://<user>:<password>@apt.balabit.hu/zorp-os/ zorp-os-3.1/3.1security zorp-os common-gpl common zorp zas zms-agent zms zcv
> deb https://<user>:<password>@apt.balabit.hu/zorp-os/ zorp-os-3.1/3.1 zorp-os common-gpl common zorp zas zms-agent zms zcv
> # GUI (debian-sarge based)
> deb https://<user>:<password>@apt.balabit.hu/zorp-os/ debian-sarge/3.1 sarge-backport zms-gui common common-gpl
> I have tried changing the deb entries to match that visible over http, eg /downloads/files/zorp but i still get 404?
> Thanks in advance for your assistance

you are using the commercial Zorp apt sources which require a password.
Are you sure you quoted your own sources.list file? because
user/password is not filled in, or you have a username + password?

There was a problem with the GPL sources though, but I've fixed them.

I've just tested this and it seems to work.

deb http://apt.balabit.hu/zorp-gpl-os zorp-os-3.1/3.1 common-gpl  common-gpl-dev  zorp-gpl  zorp-os  zorp-os-dev  zorp-os-extra


More information about the zorp mailing list