[tproxy] iptables 1.3.8 problem

Laszlo Attila Toth panther at balabit.hu
Thu Sep 20 09:41:41 CEST 2007


When I removed the module xt_TPROXY from memory and its file in 
/lib/modules (xt_TPROXY.ko) I got the same error message:

iptables -t tproxy -A PREROUTING -j TPROXY --on-port 80
ptables: No chain/target/match by that name

It is not in the compiled kernel. Did you set both tproxy match and 
TPROXY target in Core netfilter group?

If not: If you configured xtables (Core netfilter) first and then 
iptables (IP: Netfilter Configuration), only tproxy match is available 
in the xtables section. In the other configuration group you can set 
transparent proxying (tproxy table), and after that TPROXY target is 
available in xtables group in Core netfilter.

Vects írta:
> On Wed, 2007-09-19 at 17:49 +0200, Laszlo Attila Toth wrote:
>> Hello,
>> I tried it as you did, but it works.
>> By default extensions/.tproxy-test is not executable this may be a 
>> problem because without it tproxy match and target modules of iptables 
> I paid attention to that and use chmod on .tproxy-test as written in
> readme. I've got and error message about --on-port with 
> 'iptables -t tproxy -A PREROUTING -j TPROXY'. 
> Plus I found libipt_tproxy.so in /usr/local/lib/iptables after
> installation of iptables.
> Thanks, Alexc.
>> won't be compiled. I have no other idea.
>> Vects írta:
>>> iptables has failed
>>> # iptables -t tproxy -A PREROUTING -j TPROXY --on-port 80
>>> iptables: No chain/target/match by that name
>>> I guess I missed something, please advise.
>>> Thanks, Alexc


More information about the tproxy mailing list