[syslog-ng] CentOS cant start syslog-ng via systemd but runs fine manually

Kókai Péter peter.kokai at balabit.com
Mon Sep 11 05:18:58 UTC 2017


Could you please give more information about your system?
Which version of
* syslog-ng
* java
* centos
are you using?
If possible which version of java have you used before?

Your environment variables related to java?
Your syslog-ng configuration?


On Mon, 11 Sep 2017, 7:12 am Andrew <toranagtrx at gmail.com> wrote:

> I recently updated my CentOS server so there were new versions of Java and
> syslog-ng and I have been having issues ever since.
> If I run it from systemd then it fails to load, yet if I run it manually
> it works fine and pushes the logs into elasticsearch. When trying to run
> from systemd it complains about Java plugin not being found.
> systemctl start syslog-ng
> Error parsing destination, destination plugin java not found in
> destination block elasticsearch2 at line 2, column 3
> If I run it manually by typing syslog-ng then it works just fine.
> ______________________________________________________________________________
> Member info: https://lists.balabit.hu/mailman/listinfo/syslog-ng
> Documentation:
> http://www.balabit.com/support/documentation/?product=syslog-ng
> FAQ: http://www.balabit.com/wiki/syslog-ng-faq
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.balabit.hu/pipermail/syslog-ng/attachments/20170911/a28b3c80/attachment.html>

More information about the syslog-ng mailing list