[syslog-ng] Syslog-ng, centos7 and systemd seem to hate each other

Clayton Dukes cdukes at logzilla.net
Fri Feb 10 21:32:21 UTC 2017

…or at the very least, say bad things when the other is not looking :)

I did a bit of googling for this and found other people with similar issues, but could not find the fix.
This is on a cos7.0 box (not 7.2) running syslog-ng v3.9 (user did have v3.5 but I tried upgrading him to resolve this).
If I run syslog-ng -Fdve it works fine and sends everything to our python program destination
However, if I use the systemd script provided with syslog-ng, then I get nothing.
If I tell sng to just log to a file (no filters, etc.), then it works.
If I tell sng to just use the program dest (no filters, etc.) it does NOT work.

If I do a 'systemctl stop syslog-ng' and then just simply type 'syslog-ng' (no foreground, debug, etc. switches) from the command line, it works fine.
Rather confusing, but I can't see why the systemctl file is not working as it should.
Any ideas?

Other references:

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.balabit.hu/pipermail/syslog-ng/attachments/20170210/3f632221/attachment-0001.html>

More information about the syslog-ng mailing list