[syslog-ng] json configure problem in 3.4

Gergely Nagy algernon at balabit.hu
Fri Mar 23 12:26:55 CET 2012

Peter Czanik <czanik at balabit.hu> writes:

> Hello,
> First I ran into this on FreeBSD, but now also checked on Linux. If I 
> run configure without arguments, then json is found by configure:
>    JSON support (module)       : parser=yes, formatter=yes (using json-c)
> On the other hand, if I run: ./configure --with-json=json-c
> Then it fails with:
> configure: error: Cannot find json-c version >= 0.9: is pkg-config in path?

I found this one. I've been hitting my desk with my face for the past
few minutes.. such a stupid error on my part!

There was a check in configure.in, that tried to decide whether to check
for json-glib or json-c, and it read somewhat like this:

if test "x$with_json" = "json-c"; then

Obviously, that'll never happen, because we prefix $with_json with an
"x". Ouch.

> Also, there is no way to disable json support, which is a problem for 
> packagers or the FreeBSD ports system. A "--with-json=none" could solve 
> this.

I sent a patch along with the one correcting the first mistake that adds
support for --without-json and --with-json=no. I can add
--with-json=none too, but... --without-json was easier, as half of the
support was already in.


More information about the syslog-ng mailing list