[syslog-ng] make error syslog-ng 3.3.4 AIX 5.2

Rakesh Rajasekharan rakesh.rajasekharan at gmail.com
Tue Jun 26 07:42:29 CEST 2012

Yes , the results are the same even after trying to set the LDFLAGS.
export LDFLAGS="-liconv"

below is the final o/p from my configure command.

syslog-ng Open Source Edition 3.3.4 configured
 Compiler options:
  compiler                    : gcc -std=gnu99
  compiler options            : -g -O2 -Wall -pthread -D_LARGE_FILES=1
-pthread -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include
-I$(top_srcdir)/lib/ivykis/modules/include -D_GNU_SOURCE
  linker flags                : -liconv -Wl,-brtl
  prefix                      : /opt/soe/local/syslog-ng-3.3.4
  linking mode                : dynamic
  __thread keyword            : no
  ivykis                      : internal
  libmongo-client             : no
  Debug symbols               : no
  GCC profiling               : no
  Memtrace                    : no
  IPV6 support                : yes
  spoof-source support        : no
  tcp-wrapper support         : no
  Linux capability support    : no
  PCRE support                : no
  Env wrapper support         : no
  systemd support             : no (unit dir: none)
  Module search path          : /opt/soe/local/syslog-ng-3.3.4/lib/syslog-ng
  Default module list         :
  Sun STREAMS support (module): no
  SSL support (module)        : no
  SQL support (module)        : no
  PACCT module (EXPERIMENTAL) : no
  MongoDB destination (module): no
  JSON support (module)       : no (using no

and the failed lines of code are below.

libtool: link: gcc -std=gnu99 -shared -o .libs/libsyslog-ng-3.3.4.so
.libs/afinter.o .libs/alarms.o .libs/apphook.o .libs/block-ref-parser.o
.libs/center.o .libs/cfg.o .libs/cfg-lexer.o .libs/cfg-parser.o
.libs/children.o .libs/compat.o .libs/control.o .libs/dgroup.o
.libs/dnscache.o .libs/driver.o .libs/filter.o .libs/filter-expr-parser.o
.libs/globals.o .libs/gprocess.o .libs/gsockaddr.o .libs/gsocket.o
.libs/logmatcher.o .libs/logmpx.o .libs/logmsg.o .libs/logparser.o
.libs/logpipe.o .libs/logprocess.o .libs/logproto.o .libs/logqueue.o
.libs/logqueue-fifo.o .libs/logreader.o .libs/logrewrite.o
.libs/logsource.o .libs/logstamp.o .libs/logtransport.o .libs/logwriter.o
.libs/mainloop.o .libs/memtrace.o .libs/messages.o .libs/misc.o
.libs/msg-format.o .libs/nvtable.o .libs/parser-expr-parser.o
.libs/persist-state.o .libs/plugin.o .libs/pragma-parser.o
.libs/rewrite-expr-parser.o .libs/scratch-buffers.o .libs/serialize.o
.libs/sgroup.o .libs/stats.o .libs/str-format.o .libs/syslog-names.o
.libs/tags.o .libs/templates.o .libs/timeutils.o .libs/utils.o
.libs/value-pairs.o .libs/cfg-lex.o .libs/cfg-grammar.o
.libs/filter-expr-grammar.o .libs/block-ref-grammar.o
.libs/pragma-grammar.o .libs/parser-expr-grammar.o
-L/usr/local/lib -liconv -lrt -lnsl /usr/local/lib/libgmodule-2.0.a
/usr/local/lib/libgthread-2.0.a /usr/local/lib/libglib-2.0.a -lintl
-L/opt/soe/local/syslog-ng-3.3.4/eventlog/lib -levtlog -ldl
-lc -Wl,-bnoentry  -O2 -pthread -Wl,-brtl -pthread -Wl,--whole-archive
-Wl,--no-whole-archive   -pthread -Wl,-bE:.libs/libsyslog-ng.exp
/usr/local/lib/libglib-2.0.a(gconvert.o):gconvert.c:(.pr+0x12c): undefined
reference to `.libiconv_open'
/usr/local/lib/libglib-2.0.a(gconvert.o):gconvert.c:(.pr+0x358): undefined
reference to `.libiconv'
/usr/local/lib/libglib-2.0.a(gconvert.o):gconvert.c:(.pr+0x39c): undefined
reference to `.libiconv_close'
collect2: ld returned 1 exit status
make[4]: *** [libsyslog-ng.la] Error 1
make[4]: Leaving directory `/tmp/compile/syslog/syslog-ng-3.3.4/lib'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/tmp/compile/syslog/syslog-ng-3.3.4/lib'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/tmp/compile/syslog/syslog-ng-3.3.4/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/compile/syslog/syslog-ng-3.3.4'
make: *** [all] Error 2

I have compiled glib 2.16.5 using thje configure options
./configure --enable-static -with-libiconv

and libiconv was run without any options supplied to the configure

On Fri, Jun 22, 2012 at 7:20 PM, Gergely Nagy <algernon at balabit.hu> wrote:

> (No need to Cc me on list mail, thank you)
> Rakesh Rajasekharan <rakesh.rajasekharan at gmail.com> writes:
> > Hello Gergely,
> >
> > I have tried including -liconv  by adding CFLAGS="-liconv", but that did
> > not help. I am not sure if that this is the right means to include
> -liconv
> > or something else.
> LDFLAGS would be the place, I believe. Do you get the same error if you
> put it there? If so, can you post the whole failing command and its
> output?
> --
> |8]
> ______________________________________________________________________________
> Member info: https://lists.balabit.hu/mailman/listinfo/syslog-ng
> Documentation:
> http://www.balabit.com/support/documentation/?product=syslog-ng
> FAQ: http://www.balabit.com/wiki/syslog-ng-faq
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.balabit.hu/pipermail/syslog-ng/attachments/20120626/67caf356/attachment.htm 

More information about the syslog-ng mailing list