[syslog-ng] 3.4 on opensuse factory

Peter Czanik czanik at balabit.hu
Sat Apr 21 15:53:25 CEST 2012

On 04/20/2012 04:45 PM, Gergely Nagy wrote:
> Peter Czanik<czanik at balabit.hu>  writes:
>> Hello,
>> When trying to run syslog-ng 3.4 on openSUSE factory, the supervisor
>> process starts, but it's child segfaults continuously. I tried to revert
>> the big nvtable patch, which solved my problem previously, but it did
>> not help.
> It's not the nvtable patch that causes problems. I posted a patch here
> earlier that fixes the issue, but it hasn't been pulled into 3.4 yet (it
> was, Bazsi just didn't push his tree out, it seems).
> The patch itself is available on my sandbox/3.4 branch, in this commit:
>   https://github.com/algernon/syslog-ng/commit/05e4e594e1fda8d91188196365fdc30da303254d
>> Is it something in syslog-ng, or I should rather report it at openSUSE?
> It's a syslog-ng 3.4 bug, patch above :)
And it fixed my problem! Thanks!

Peter Czanik (CzP)<czanik at balabit.hu>
BalaBit IT Security / syslog-ng upstream

More information about the syslog-ng mailing list