[syslog-ng] SSL compile errors even when configured without ssl support

Balazs Scheidler bazsi at balabit.hu
Thu Jan 22 10:39:52 CET 2009

On Wed, 2009-01-21 at 10:06 -0600, Chris Fabri wrote:
> Greetings-
> I'm trying to compile syslog-ng 3.0.1 on RH 3 (yes, I know), and am
> unable to compile due to what appear to be openssl related errors:
> In file included from tlscontext.h:12,
>                  from tlscontext.c:1:
> /usr/include/openssl/ssl.h:909: syntax error before "KSSL_CTX"
> /usr/include/openssl/ssl.h:931: syntax error before '}' token
> Are the last set.  However, I ran configure with "--disable-ssl."
> Reviewing some of the archives, it appears this was fixed in v3.0 back
> in Nov '08:
> https://lists.balabit.hu/pipermail/syslog-ng/2008-November/012234.html
> I've tried the 11202008 build just in case, and that didn't 'seem to
> resolve the problem.  I really don't need SSL, so it would be much
> simpler to just skip the SSL part than try to get it working to get
> around this error.     Various searches of the archives have mentioned
> that this was fixed a few other times, but I'm not having any luck.

Hmm... the configure script gives a summary on compilation flags at the
end of the configure phase. Do you have openssl enabled or disabled

The config.h and config.log files could also help....

I've checked again, this might be the culprit. Last time I've fixed
this, I probably didn't get a positive response that the fix was
successful. And the problem is that ENABLE_SSL is actually defined even
if SSL is disabled, but its value is 0, so instead of #ifdef, #if needs
to be used.

Can you check if this fixes your problem and also report it back?


diff --git a/src/tlscontext.h b/src/tlscontext.h
index ada8e18..ce4bbf8 100644
--- a/src/tlscontext.h
+++ b/src/tlscontext.h
@@ -7,7 +7,7 @@
 #include "syslog-ng.h"
-#ifdef ENABLE_SSL
 #include <openssl/ssl.h>


More information about the syslog-ng mailing list