[syslog-ng] SSL compile errors even when configured without ssl support

Chris Fabri fabric at northwestern.edu
Wed Jan 21 17:06:01 CET 2009


I'm trying to compile syslog-ng 3.0.1 on RH 3 (yes, I know), and am
unable to compile due to what appear to be openssl related errors:

In file included from tlscontext.h:12,
                 from tlscontext.c:1:
/usr/include/openssl/ssl.h:909: syntax error before "KSSL_CTX"
/usr/include/openssl/ssl.h:931: syntax error before '}' token

Are the last set.  However, I ran configure with "--disable-ssl."
Reviewing some of the archives, it appears this was fixed in v3.0 back
in Nov '08:


I've tried the 11202008 build just in case, and that didn't 'seem to
resolve the problem.  I really don't need SSL, so it would be much
simpler to just skip the SSL part than try to get it working to get
around this error.     Various searches of the archives have mentioned
that this was fixed a few other times, but I'm not having any luck.

Help?    :)    chris

More information about the syslog-ng mailing list