[tproxy] tproxy 4.1 squid 3.1.19 not working for yahoo mail

Ming-Ching Tiew mctiew at yahoo.com
Fri Jul 13 09:54:09 CEST 2012

----- Original Message -----
From: KOVACS Krisztian <hidden at balabit.hu>

> Have you tried reporting this issue to the squid mailing list? 
> Unfortunately I'm not a squid expert -- and even if this was not a 
> squid issue -- a solid knowledge of Squid internals is most probably 
> necessary to successfully triage the bug.

Thank you for responding to this post. I reported to squid forum, but I 
could not get any response, I suspect all the squid developers are not really
using squid in tproxy mode - the needed setup is troublesome for them 
to repeat the problem or perhaps they don't even think it could be squid 
problem. :)

Basically the problem I see is even seen since squid 2.6 on kernel 2.6.25
( I worked on squid/tproxy back then ).

So far I found two websites giving the problem when running squid in tproxy 
mode, so I can safely conclude that it's not a https problem. 

But I thought yahoo mail is a very common thing, why nobody seem to complain 
about this whereas I could see this in all versions of squid, all version of 

More information about the tproxy mailing list