[tproxy] Tproxy4

Marko Kotar kotarmarko at yahoo.com
Wed Nov 11 16:56:09 CET 2009

I am trying to get TPROXY4 work on mentioned kernel. I've tryed to patch it with patch for 2.6.25 kernel. there were some conflicts but i think ive solved them. But tproxy didn't work. So i ve tryed another patch from wt6 kernel found here: http://linux.1wt.eu/alix/kernel-src/2.6.27-wt6/patches-2.6.27-wt6.tar.bz2.
But it still doesn't work.
What I have found out:

If i create a bridge between interfaces packets go through only if process is listening on tproxy port. They don't get through or get to listening process.

If I modify packet flow with ebtables to go through by routing doesn't come out(borute target-redirect accept or drop) or to listening process.
If i use interfaces to be routed also packets don't get through or to listening process.
Nothing happens.

I was suspecting route.c is not working as it should so i've used it from next version of kernel where tproxy4 is working.But no difference at all.

Also TPROXY4 is working fine with connect().

I set device according to: http://wiki.squid-cache.org/Features/Tproxy4(ebtables without -i option and also tried with ACCEPT option)
All settings were working on 2.6.28 Ubuntu-x86_64 kernel.

What could be wrong? Any clues? Where in the kernel code packets are going to tcp?

Thanks to anyone who has any idea about that.



More information about the tproxy mailing list