[tproxy] Tproxy Problem

KOVACS Krisztian hidden@balabit.hu
Wed, 06 Apr 2005 11:35:37 +0200


2005-04-06, sze keltezéssel 10.57-kor Karthika_Rallabandi ezt írta:
> Thanks for the immediate response. 
> Yeah I applied the patch for iptables user space.
> I downloaded the iptables-1.2.9 and performed the following steps as
> mentioned in README
> 	cd /usr/src/iptables-1.2.9
> 	cat <pathtocttproxy>/iptables/*.diff | patch -p1
> 	make KERNELDIR=/usr/src/linux
> But I couldn't find libipt_TPROXY.so in /lib/iptables.
> I tried to compile libipt_TPROXY.c in iptables/extensions/libipt_TPROXY.c
> but couldn't succeed. It gave errors in .h files like INT_MIN undeclared
> etc.
> I tried to include kernel.h file also but of no use.

  Ok, then please try the following

      * apply the kernel patch first, and make sure you set KERNELDIR to
        the path of the patched source
      * after applying the iptables patch, make sure that
        extensions/.tproxy-test is executable:

  Krisztian Kovacs