[syslog-ng] syslog-ng logging only as foreground process and not as daemon on centos7

Jordan Ladora vicepresjoebiden at gmail.com
Wed Feb 8 16:10:56 UTC 2017

I've got syslog-ng v3.7.3_7 running on FreeBSD 11-REL as the log server
with both FreeBSD 11-REL and CentOS7 clients (the CentOS clients are
running v3.5.6-3.el7 as it's the latest version installed by yum epel

It's always worked perfectly on the FreeBSD systems, but a few months ago I
had the same problem described here when setting up a CentOS client-


...I followed the fix of uncommenting the "ForwardToSyslog=yes" line
in /etc/systemd/journald.conf
and it started logging perfectly on CentOS clients, too.

However, in setting up another CentOS7 client yesterday, this fix no longer
worked. If I start syslog-ng via-

chkconfig syslog-ng on
systemctl restart syslog-ng.service

..it starts and runs and is shown in ps, starts automatically after reboot,
but doesn't log to the server. If I start it manually from the terminal

nohup /usr/sbin/syslog-ng -F -p /var/run/syslogd.pid &

...then it does work and starts logging to the server immediately. In that
case there are two identical (except for pid) lines shown by ps, e.g.-

482 /usr/sbin/syslog-ng -F -p /var/run/syslogd.pid
904 /usr/sbin/syslog-ng -F -p /var/run/syslogd.pid

...but only the one I started from the terminal (nohup...) actually logs.

Any help would be much appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.balabit.hu/pipermail/syslog-ng/attachments/20170208/98167cde/attachment.html>

More information about the syslog-ng mailing list