[syslog-ng] [Bug 266] New: localport option does not bind to a specific port

bugzilla at bugzilla.balabit.com bugzilla at bugzilla.balabit.com
Wed Dec 18 17:41:56 CET 2013


           Summary: localport option does not bind to a specific port
           Product: syslog-ng
           Version: unspecified
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: unspecified
         Component: syslog-ng
        AssignedTo: bazsi at balabit.hu
        ReportedBy: zebaz at xs4all.nl
Type of the Report: bug
   Estimated Hours: 0.0

The localport option to specify a source port when opening a TCP connection no longer seems to be working. For testing I used the following simplified

@version: 3.5
source src {
    unix-stream("/dev/log" max-connections(256));
destination logcentral { 
  tcp("logcentral" port(514) localport(1014));
  log { source(src); destination(logcentral); };

When running syslog-ng -d the relevant output is:

Syslog connection established; fd='8', server='AF_INET(<ip removed>:514)', local='AF_INET('

I tried some variations in the configuration:

- source port > 1024 gives the same result
- specifying the localip option binds the local socket explicitly to that IP address but still not to a specific port

Behaviour has been checked to occur with versions 3.4.2 and 3.4.6 from Gentoo as well as 3.5.2 from the upstream site (compiled from source). Other
installations with identical kernel versions run older syslog-ng installations (3.2.x and 3.3.x) with the same settings without a problem.

Configure bugmail: https://bugzilla.balabit.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the syslog-ng mailing list