[syslog-ng] afsql error

Jose Pedro Oliveira jpo at di.uminho.pt
Sat Apr 21 00:04:51 CEST 2012


Jason,

Just install the syslog-ng-libdbi subpackage for enabling the SQL
support (i.e. assuming that you have installed syslog-ng from the
EPEL repositories):

    yum install syslog-ng-libdbi

Regards,
jpo

On Fri, 20 Apr 2012 15:44:47 -0500, Jason Kojro-Badziak
<jbadziak at monolith-software.com> wrote:
> I apologize, I ran the command on the wrong system.  Here is the actual
> results of the command:
> 
> 	# syslog-ng --version
> 	syslog-ng 3.2.5
> 	Installer-Version: 3.2.5
> 	Revision:
>
	ssh+git:[email protected]//var/scm/git/syslog-ng/syslog-ng-ose--mainline--	3.2#master#9d4bea28198bd731df1a61e980a2af5b88d81116
> 	Compile-Date: Jan 15 2012 19:47:30
> 	Enable-Threads: on
> 	Enable-Debug: off
> 	Enable-GProf: off
> 	Enable-Memtrace: off
> 	Enable-Sun-STREAMS: off
> 	Enable-IPv6: on
> 	Enable-Spoof-Source: on
> 	Enable-TCP-Wrapper: on
> 	Enable-SSL: off
> 	Enable-SQL: on
> 	Enable-Linux-Caps: off
> 	Enable-Pcre: on
> 	Enable-Pacct: off
> 
> Thank you!
> 
> Jason Kojro-Badziak
> Monolith Software
> Staff Engineer
> 311 North 2nd Street, Suite #302
> St. Charles, IL 60174
> Office:  312-957-6470 x3010
> Email:  jbadziak at monolith-software.com
> 
> 
> -----Original Message-----
> From: syslog-ng-bounces at lists.balabit.hu
> [mailto:syslog-ng-bounces at lists.balabit.hu] On Behalf Of Jason
> Kojro-Badziak
> Sent: Friday, April 20, 2012 3:42 PM
> To: Syslog-ng users' and developers' mailing list
> Subject: Re: [syslog-ng] afsql error
> 
> Hello:
> 
> When I ran the --version command you specify, I am not getting the
results
> as you mentioned.  I am only being shown that I have version 2.1.4
> installed.
> 
> # /sbin/syslog-ng --version
> syslog-ng 2.1.4
> 
> I apologize, but can you please show me how I can install the afsql
> module?  While I am not using a SQL destination right now, we do plan on
> using one and I will need the module installed.
> 
> Thank you!
> 
> Jason Kojro-Badziak
> Monolith Software
> Staff Engineer
> 311 North 2nd Street, Suite #302
> St. Charles, IL 60174
> Office:  312-957-6470 x3010
> Email:  jbadziak at monolith-software.com
> 
> -----Original Message-----
> From: syslog-ng-bounces at lists.balabit.hu
> [mailto:syslog-ng-bounces at lists.balabit.hu] On Behalf Of Gergely Nagy
> Sent: Wednesday, April 18, 2012 5:29 PM
> To: syslog-ng at lists.balabit.hu
> Subject: Re: [syslog-ng] afsql error
> 
> Jason Kojro-Badziak <jbadziak at monolith-software.com> writes:
> 
>> Hello all:
>>
>> I am running syslog-ng on a Centos 6 server.  I installed syslog-ng 
>> via yum, and while it is running successfully, I am getting this error 
>> every time I start or restart syslog-ng.
>>
>> # /etc/init.d/syslog-ng start
>> Plugin module not found in 'module-path';
>> module-path='/lib64/syslog-ng', module='afsql'
>> Starting syslog-ng: Plugin module not found in 'module-path';
>> module-path='/lib64/syslog-ng', module='afsql'
>>                                                            [  OK  ]
> 
> If you're not using an SQL destination, and don't need it, you can add
>
--default-modules=affile,afprog,afsocket,afuser,basicfuncs,csvparser,dbparser,syslogformat
> to the commandline in the init script, and it will stop warning about
> afsql. Mind you, this is only a warning - syslog-ng will function just
fine
> despite the perhaps scary warning at startup.
> 
> (You can get the compiled-in default by running syslog-ng --version, and
> looking at the Default-Modules line - remove afsql from there, and pass
the
> rest via --default-modules)
> 
> If you do want to use an SQL destination, then you will need that
module.
> I do not know what package it is in, possibly something like
> syslog-ng-module-sql or something similar.

-- 
Jose Pedro Oliveira


More information about the syslog-ng mailing list