[syslog-ng] Error in FreeBSD jail

Sean McAfee smcafee at collaborativefusion.com
Thu Dec 17 18:47:22 CET 2009

Peter Fraser wrote:
> Made that change but I still get the same error.

Well, I'm sure you would've hit the klog error once this was resolved, 
so I'd hold on to that change.

> Error binding socket; addr='AF_UNIX(/var/run/log)', error='Permission
> denied (13)'
> Error initializing source driver; source='src', id='src#0'
> Error initializing message pipeline;
> /usr/local/etc/rc.d/syslog-ng: WARNING: failed to start syslog_ng
> I am starting the jail out of the rc.d directory. I do /etc/rc.d/jail
> start logging

My experience with jails is limited to using ezjail-admin. I know that 
/var/run/log and /var/run/logpriv are both created by ezjail-admin when 
jails are started.  Have you verified it exists on your system?  If it 
does, what are the perms (from the jail's perspective)?

I have the following in a 6.3 jail:
[root at host ~]# ls -la /var/run/log*
srw-rw-rw-  1 root  wheel  0 Aug 21 12:31 /var/run/log
srw-------  1 root  wheel  0 Aug 21 12:31 /var/run/logpriv

Sean McAfee
Senior Systems Engineer

More information about the syslog-ng mailing list