[syslog-ng] Syslog-ng & RedHat

syslogyk syslogyk at yandex.ru
Fri Mar 10 17:22:11 CET 2006


 Thank you for your answer. Yes, I tried to create \var\lib\named\dev . Then, I run syslog-ng again. As result, the file \var\lib\named\dev\log was created (with size of 0 byte), and I have got the same error.

 About 1.6. OK, I will try it and let you know about results.
Thank you again!

>syslogyk wrote:
>>    Hi! 
>>  I tried to work with syslog-ng-1.9.9 on Redhat Linux AS 4.
>>  Sources (eventlog and syslog-ng) were taken here: http://www.balabit.com/downloads/syslog-ng/1.9/src/
>>  I walked through configure, make and make install successfully.
>> Simple syslog-ng.conf was placed to /usr/local/etc
>> When I run /usr/local/sbin/syslog-ng, I get the following error:
>> fsync() does not work yet;
>> fsync() does not work yet;
>> Error binding socket; error='No such file or directory (2)', addr='AF_UNIX(/var/lib/named/dev/log)'
>> Error initializing source driver; source='src'
>Does the /var/lib/named/dev directory exist on your system? Syslog-ng
>creates the sockets only, not the directories.
>>   Could you please give me a hint about what was a reason of such error?
>>   Anyway, I can't tell I'm interested in last version only. So, could you please advice me syslog-ng version that worked successfully on RedHat Linux AS 4?
>You can try the 1.6 branch of syslog-ng, if 1.9 doesn't work for you. In
>the source tarball there is already the RHEL-specific packaging included
>(syslog-ng.spec.bb), so you can create the rpm package for yourself. See
>the comments in the /etc/syslog-ng/syslog-ng.conf file.

Яндекс.Почта: объем почтового ящика не ограничен! http://mail.yandex.ru/monitoring/

More information about the syslog-ng mailing list