[syslog-ng] Compilation problem with Syslog-ng-2.0rc1 in Solaris9

Bruno Maimoni bmaimoni at gmail.com
Fri Aug 4 20:31:11 CEST 2006

Hello there,

I'm having problems to compile the new syslog-ng version in a Solaris9 os.

bash-2.05# uname -a
SunOS <something> 5.9 Generic_117171-05 sun4u sparc SUNW,Ultra-5_10
gcc version: 3.3.2

I run ./configure without problems:
export PKG_CONFIG_PATH=/opt/eventlog-0.2.5/lib/pkgconfig
./configure --prefix=/opt/syslog-ng-2.0rc1 --enable-dynamic-linking

Then when i run make:
if gcc -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -I/opt/eventlog-0.2.5/include/eventlog
-D_GNU_SOURCE  -g -O2 -Wall -g -MT fdread.o -MD -MP -MF
".deps/fdread.Tpo" \
  -c -o fdread.o `test -f 'fdread.c' || echo './'`fdread.c; \
then mv -f ".deps/fdread.Tpo" ".deps/fdread.Po"; \
else rm -f ".deps/fdread.Tpo"; exit 1; \
if gcc -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -I/opt/eventlog-0.2.5/include/eventlog
-D_GNU_SOURCE  -g -O2 -Wall -g -MT memtrace.o -MD -MP -MF
".deps/memtrace.Tpo" \
  -c -o memtrace.o `test -f 'memtrace.c' || echo './'`memtrace.c; \
then mv -f ".deps/memtrace.Tpo" ".deps/memtrace.Po"; \
else rm -f ".deps/memtrace.Tpo"; exit 1; \
rm -f libsyslog-ng.a
ar cru libsyslog-ng.a misc.o utils.o messages.o syslog-names.o cfg.o
cfg-lex.o cfg-grammar.o macros.o filter.o logmsg.o logpipe.o
logsource.o driver.o sgroup.o dgroup.o center.o templates.o
logreader.o logwriter.o affile.o afstreams.o afuser.o afprog.o
afsocket.o afunix.o afinet.o afinter.o children.o stats.o gsockaddr.o
fdwrite.o fdread.o memtrace.o
ranlib libsyslog-ng.a
if gcc -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -I/opt/eventlog-0.2.5/include/eventlog
-D_GNU_SOURCE  -g -O2 -Wall -g -MT main.o -MD -MP -MF ".deps/main.Tpo"
  -c -o main.o `test -f 'main.c' || echo './'`main.c; \
then mv -f ".deps/main.Tpo" ".deps/main.Po"; \
else rm -f ".deps/main.Tpo"; exit 1; \
gcc  -g -O2 -Wall -g   -o syslog-ng  main.o libsyslog-ng.a -lpthread
-lnsl -lrt -lsocket -ldoor  -lfl -lglib-2.0
-L/opt/eventlog-0.2.5/lib -levtlog
Undefined                       first referenced
 symbol                             in file
G_UNLIKELY                          libsyslog-ng.a(filter.o)
G_LIKELY                            libsyslog-ng.a(filter.o)
ld: fatal: Symbol referencing errors. No output written to syslog-ng
collect2: ld returned 1 exit status
make[2]: *** [syslog-ng] Error 1
make[2]: Leaving directory `/tmp/teste/syslog-ng-2.0rc1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/teste/syslog-ng-2.0rc1'
make: *** [all] Error 2

Does anyone knows what's missing?

Tks in advance
[ ],s
Bruno Maimoni

More information about the syslog-ng mailing list