[syslog-ng]OpenBSD named pipe

Bobby Johnson syslog-ng@lists.balabit.hu
Mon, 17 Nov 2003 18:20:14 -0700

I'm new to the list, hope this hasn't been covered before.  I'm having some problems with syslog-ng, a named pipe and a shell script.  I've created a destination in syslog-ng.conf that points to a pipe.  In short the shell script looks like this.
  while read -r line; do
  	sort input and output to file
  done < named.pipe

Almost no matter what I do the script will sit outside the while loop not reading anything as things are input into the pipe.  If i echo "anything" > named.pipe the shell script will run through all or most(not absolutly sure on this) of the input and then exit.  I have this same setup on a FreeBSD computer and it works great, moved it to OpenBSD and it doesn't.  If I do a tail -f on the pipe while my script is running then exit the tail the script works properly.  I have tried a few different versions of syslog-ng and libol currently I have 1.6.0rc4 and 0.3.11.  I have tried bourne, bash and ksh.
Please help.

Bobby Johnson
Plexus Computer Services