[syslog-ng]crashbug fix in recent syslog-ng versions

Hamilton, Andrew Andrew.Hamilton@afccc.af.mil
Wed, 30 Oct 2002 09:22:10 -0500

I also said it might help some people.  Not everyone.  You can use it or not
as it suits you and Bazsi already came up with a better solution.  It is not
necessarily wrong just not right for everyone.  

-----Original Message-----
From: Borzenkov Andrey [mailto:Andrej.Borsenkow@mow.siemens.ru]
Sent: Wednesday, October 30, 2002 8:57 AM
To: syslog-ng@lists.balabit.hu
Subject: RE: [syslog-ng]crashbug fix in recent syslog-ng versions

> Well with a couple of changes I got it to work correctly on Solaris 8
> I ran configure a bunch of times with various corrections to
> because I originally got the HAVE_RES_INIT problem like the others
> Then of course the link problem with -lresolv came up during the
> But I used the patch that Andrey sent for acconfig.h then I added a
> to
> configure.in and voila! it worked perfectly for me "out of the box" so
> speak.
> *** configure.in.orig   Tue Oct 29 20:00:52 2002
> --- configure.in        Tue Oct 29 20:20:34 2002
> ***************
> *** 151,156 ****
> --- 151,157 ----
>   if test "x$blb_cv_c_res_init" = "xyes"; then
> +       LIBS="$LIBS -lresolv"
>   fi
>   dnl Checks for library functions.

This patch is obviously wrong. You cannot assume that libresolv exists
just because res_init is found in some header. What is the right thing
to do is to search for library that contains res_init.


syslog-ng maillist  -  syslog-ng@lists.balabit.hu
Frequently asked questions at http://www.campin.net/syslog-ng/faq.html