[syslog-ng]Re: syslog-ng-1.5.21 on Solaris8

Balazs Scheidler bazsi@balabit.hu
Tue, 15 Oct 2002 15:08:02 +0200

On Tue, Oct 15, 2002 at 12:16:13PM +0200, Sean Boran wrote:
> Hi,
> I'm a new comer to syslog-ng and wanted to try it out on Solaris.
> I wish to use the 1.5 branch so I can perhaps divert to sql later..
> Anyway, I run configure with no options and the make.
> It compiles all modules but fails on linking:
> "gcc  -g -O2 -Wall -I/usr/local/include/libol -D_GNU_SOURCE  -o
> syslog-ng  main.o sources.o center.o filters.o destinations.o  log.o
> cfgfile.o cfg-grammar.o cfg-lex.o affile.o afsocket.o afunix.o  afinet.o
> afinter.o afuser.o afstreams.o afprogram.o afremctrl.o  nscache.o
> utils.o syslog-names.o getopt.o getopt1.o -lpthread -ldoor
> /usr/local/lib/libol.a -l
> socket -lnsl -lxnet
> Undefined                       first referenced
>  symbol                             in file
> res_init                            main.o
> yywrap                              cfg-lex.o
> ld: fatal: Symbol referencing errors. No output written to syslog-ng
> collect2: ld returned 1 exit status"
> - Then I though maybe I should install FLEX, so I installed flex-2.5.4a,
> and redid the configure and make, the result is the same.
> - libol-0.3.3 compiled and installed just fine.
> - I'm compiled on Solaris 8 sun4u, with pretty recent patches, if that
> helps.
> - I know litte about flex, so was unsure how to proceed with debugging..
> - I see one reference to res_init in main.c, but no explanation as what
> is is or where it comes from..
> Have you any tips for me?

res_init can be solved by adding -lresolv to link flags.

yywrap can be solved by linking against -lfl (part of flex) instead of
simply -ll (part of lex as distributed with Solaris)

res_init() seems to be platform dependant, so I added a configure test in
1.5.22 (which has been released, but not uploaded to our website)

PGP info: KeyID 9AF8D0A9 Fingerprint CD27 CFB0 802C 0944 9CFD 804E C82C 8EB1