[syslog-ng]syslog-ng mysteriously exits

Ed Ravin eravin@panix.com
Fri, 8 Feb 2002 13:40:02 -0500 (EST)

John Coke writes:
> getpid()                                = 3616
> time(NULL)                              = 1013148201
> rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
> getpid()                                = 3616
> kill(3616, SIGABRT)                     = 0
> --- SIGABRT (Aborted) ---
> I have not been able to find a clear picture of what causes SIGABRT.

This is self-inflicted - note that the process looks up its own process
ID number (getpid()), diddles the signal mask (I'm guessing it's to
enable SIGABRT), then kills itself.  syslog-ng has probably detected
something very wrong, and is trying to leave you a core dump so you
can figure out what happened.

So my next question is - where's the core dump?  It should show up in
the current directory of the daemon.  Use "lsof" while the daemon is
running to see what directory it is in, and check there.  Or do a
global find and hunt it down.

Also, have you tried upgrading to the latest syslog-ng (1.5.14 or so)?
Except for one small bug :-) it's worked pretty well for me.