[syslog-ng]Syslog.conf translator

Balazs Scheidler bazsi@balabit.hu
Sun, 6 May 2001 11:27:50 +0200

On Fri, May 04, 2001 at 05:31:11PM -0500, Jon Marks wrote:
> Hi,
> I've tried out the copy of the awk script syslog2ng incorporated into
> the development branch contrib directory-- but it won't run. It's a
> parse error that only seems to crop up when awk is fed this program on
> its stdin, but not as a command line argument. I'm still not sure why
> it doesn't work-- what about its parsing would change using -f? Any
> seasoned awk programmers out there want to help out? I'm grateful for
> any advice! It's always the same syntactic construct that causes the
> error:
>         # Handle the various platforms- determine proper log device
>         "/bin/uname -s" | getline sysname;      # <-- ERROR HERE!!
>         close("/bin/uname -s");

I'm no AWK expert, so I can't solve your problem, I just wanted to add that
it does run on Linux. (Debian potato)

PGP info: KeyID 9AF8D0A9 Fingerprint CD27 CFB0 802C 0944 9CFD 804E C82C 8EB1